$re = '/20(?=(?:[\da-fA-F]{2})*$)/';
$str = '324F8D8A20561205231920';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);