import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(Accumulated Earnings Tax\\.).+?\\n(.*\\.)";
final String string = "Accumulated Earnings Tax. \n"
+ " A tax penalty which is imposed on corporate earnings which are retained by the corporation for non-business related needs. \n\n"
+ " Acquisition Cost. \n"
+ " The expenses incurred by an insurer or reinsurance company that are directly related to putting the business on the books of the company. The largest portion of this cost is usually the agent's or sales representative's commission or bonus. \n\n"
+ " Act of God. \n"
+ " An event arising out of natural causes with no human intervention which could not have been prevented by reasonable care or foresight. Examples are floods, lightning, and earthquakes. \n\n"
+ " Actual Cash Value. \n"
+ " An amount equivalent to the replacement cost of lost or damaged property at the time of the loss, less depreciation. With regard to buildings, there is a tendency for the actual cash value to closely parallel the market value of the property. See also Market Value. ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}