const regex = /(Accumulated Earnings Tax\.).+?\n(.*\.)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(Accumulated Earnings Tax\\.).+?\\n(.*\\.)', '')
const str = `Accumulated Earnings Tax.
A tax penalty which is imposed on corporate earnings which are retained by the corporation for non-business related needs.
Acquisition Cost.
The expenses incurred by an insurer or reinsurance company that are directly related to putting the business on the books of the company. The largest portion of this cost is usually the agent's or sales representative's commission or bonus.
Act of God.
An event arising out of natural causes with no human intervention which could not have been prevented by reasonable care or foresight. Examples are floods, lightning, and earthquakes.
Actual Cash Value.
An amount equivalent to the replacement cost of lost or damaged property at the time of the loss, less depreciation. With regard to buildings, there is a tendency for the actual cash value to closely parallel the market value of the property. See also Market Value. `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}