use strict;
my $str = '<!-- Should match -->
<element
attribute="value"
desiredAttr1="desiredValue1"
desiredAttr2="desiredValue2"
>
<!-- Should match -->
<element
attribute="value"
desiredAttr2="desiredValue2"
>
<!-- Should match -->
<element attribute="value" desiredAttr1="desiredValue1">
<!-- Should match -->
<element desiredAttr2="desiredValue2" attribute="value">
<!-- Should NOT match -->
<element
attribute="value"
notDesiredAttr1="desiredValue1"
notDesiredAttr2="desiredValue2"
>
<span style="background: red;"> </span><code><element<br/>
attribute="value"<br/>
desiredAttr1="desiredValue1"<br/>
desiredAttr2="desiredValue2"<br/>
></code>';
my $regex = qr/^[\p{Zs}\t]*(?=<element\b[^<>\r]*\bdesiredAttr([12])="desiredValue\1"[^<>\r]*>)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}