$re = '/^[\p{Zs}\t]*(?=<element\b[^<>\r]*\bdesiredAttr([12])="desiredValue\1"[^<>\r]*>)/m';
$str = '<!-- Should match -->
<element
attribute="value"
desiredAttr1="desiredValue1"
desiredAttr2="desiredValue2"
>
<!-- Should match -->
<element
attribute="value"
desiredAttr2="desiredValue2"
>
<!-- Should match -->
<element attribute="value" desiredAttr1="desiredValue1">
<!-- Should match -->
<element desiredAttr2="desiredValue2" attribute="value">
<!-- Should NOT match -->
<element
attribute="value"
notDesiredAttr1="desiredValue1"
notDesiredAttr2="desiredValue2"
>
<span style="background: red;"> </span><code><element<br/>
attribute="value"<br/>
desiredAttr1="desiredValue1"<br/>
desiredAttr2="desiredValue2"<br/>
></code>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);