package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\"(?:\\\"|[^\"])*\"`)
var str = `some text "some tetx"
few "text are \" escaped" "once again"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}