const regex = /^(\w+)((?=_(L|R))(?=_\d{0,4}))?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\w+)((?=_(L|R))(?=_\\d{0,4}))?', 'gm')
const str = `KEEP_THIS_L_1234
KEEP_THIS_R_12
KEEP_THIS`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}