re = /^(\w+)((?=_(L|R))(?=_\d{0,4}))?/m
str = 'KEEP_THIS_L_1234
KEEP_THIS_R_12
KEEP_THIS'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end