$re = '/<Properties>(?:(?!<\/Properties>)[^])*%%(.+?)%%(?:(?!<\/Properties>)[^])*<\/Properties>/m';
$str = '<Properties>
<Property>TEXT</Property>
</Properties>
<Properties>
<Property >%%TEXT%%</Property
</Properties>
<Properties>
<Property>TEXT</Property>
</Properties>
<Properties>
<Property >%%TEXT%%</Property
</Properties>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);