import re
regex = re.compile(r"<Properties>(?:(?!<\/Properties>)[^])*%%(.+?)%%(?:(?!<\/Properties>)[^])*<\/Properties>", flags=re.MULTILINE)
test_str = ("<Properties>\n"
"<Property>TEXT</Property>\n"
"</Properties>\n"
"<Properties>\n"
"<Property >%%TEXT%%</Property\n"
"</Properties>\n"
"<Properties>\n"
"<Property>TEXT</Property>\n"
"</Properties>\n"
"<Properties>\n"
"<Property >%%TEXT%%</Property\n"
"</Properties>\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")