#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:https?:\/\/)?(?:www\.)?youtu\.?be(?:\.com)?.*?(?:v|list)=(.*?)(?:&|$)|^(?:https?:\/\/)?(?:www\.)?youtu\.?be(?:\.com)?(?:(?!=).)*\/(.*)$"
Local $sString = "Extract Playlist ID For" & @CRLF & _
"" & @CRLF & _
"https://www.youtube.com/playlist?list=PLuC2HflhhpLGQ4RgqA76_Gv52fGA0909r" & @CRLF & _
"www.youtube.com/playlist?list=PLuC2HflhhpLGQ4RgqA76_Gv52fGA0909r" & @CRLF & _
"http://www.youtube.com/playlist?list=PLuC2HflhhpLGQ4RgqA76_Gv52fGA0909r" & @CRLF & _
"https://www.youtube.com/embed/videoseries?list=PLuC2HflhhpLGQ4RgqA76_Gv52fGA0909r " & @CRLF & _
"Extract Video ID For" & @CRLF & _
"" & @CRLF & _
"https://www.youtube.com/watch?v=fqMfRi2gJok&index=1&list=PLuC2HflhhpLGQ4RgqA76_Gv52fGA0909r" & @CRLF & _
"https://www.youtube.com/watch?v=fqMfRi2gJok" & @CRLF & _
"http://youtu.be/cCnrX1w5luM " & @CRLF & _
"http://youtube.com/embed/cCnrX1w5luM" & @CRLF & _
"http://youtube.com/v/cCnrX1w5luM" & @CRLF & _
"https://www.youtube.com/v/cCnrX1w5luM" & @CRLF & _
"www.youtube.com/v/cCnrX1w5luM" & @CRLF & _
"youtube.com/v/cCnrX1w5luM" & @CRLF & _
"xyz.com/v/cCnrX1w5luM "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")