import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:https?:\\/\\/)?(?:www\\.)?youtu\\.?be(?:\\.com)?.*?(?:v|list)=(.*?)(?:&|$)|^(?:https?:\\/\\/)?(?:www\\.)?youtu\\.?be(?:\\.com)?(?:(?!=).)*\\/(.*)$";
final String string = "Extract Playlist ID For\n\n"
+ "https://www.youtube.com/playlist?list=PLuC2HflhhpLGQ4RgqA76_Gv52fGA0909r\n"
+ "www.youtube.com/playlist?list=PLuC2HflhhpLGQ4RgqA76_Gv52fGA0909r\n"
+ "http://www.youtube.com/playlist?list=PLuC2HflhhpLGQ4RgqA76_Gv52fGA0909r\n"
+ "https://www.youtube.com/embed/videoseries?list=PLuC2HflhhpLGQ4RgqA76_Gv52fGA0909r \n"
+ "Extract Video ID For\n\n"
+ "https://www.youtube.com/watch?v=fqMfRi2gJok&index=1&list=PLuC2HflhhpLGQ4RgqA76_Gv52fGA0909r\n"
+ "https://www.youtube.com/watch?v=fqMfRi2gJok\n"
+ "http://youtu.be/cCnrX1w5luM \n"
+ "http://youtube.com/embed/cCnrX1w5luM\n"
+ "http://youtube.com/v/cCnrX1w5luM\n"
+ "https://www.youtube.com/v/cCnrX1w5luM\n"
+ "www.youtube.com/v/cCnrX1w5luM\n"
+ "youtube.com/v/cCnrX1w5luM\n"
+ "xyz.com/v/cCnrX1w5luM ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}