using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\w+\s\d+(st)?(nd)?(rd)?(th)?,\s+\d+";
string input = @"[1] ""\r\n Washington,\r\n Jan 5, 2011""";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}