package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\+40\d{8}$`)
var str = `+4045678945
a04055665566`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}