$re = '/^\+40\d{8}$/';
$str = '+4045678945
a04055665566';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);