package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d{2}[.\-\s]+`)
var str = `01. A little love (2002)
02 - No.1 Star
03 Love Story`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}