re = /\d{2}[.\-\s]+/m
str = '01. A little love (2002)
02 - No.1 Star
03 Love Story'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end