# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?:https?:\\/\\/)?[^\\/\s]*?\.([^.\s\\/]*\.(?:co\.uk|[^.\s\\/]*))(?:$|\\/.*)/$1/gm;t' <<< "http://therealzenstar.blogspot.fr
http://therealzenstar.blogspot.fr/
http://therealzenstar.blogspot.fr/some_test.domain.html
http://therealzenstar.blogspot.co.uk/some_test.domain.html"