use strict;
my $str = 'http://therealzenstar.blogspot.fr
http://therealzenstar.blogspot.fr/
http://therealzenstar.blogspot.fr/some_test.domain.html
http://therealzenstar.blogspot.co.uk/some_test.domain.html';
my $regex = qr/^(?:https?:\/\/)?[^\/\s]*?\.([^.\s\/]*\.(?:co\.uk|[^.\s\/]*))(?:$|\/.*)/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";