package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)step (\w)`)
var str = `Step C must be finished before step A can begin.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}