$re = '/step (\w)/mi';
$str = 'Step C must be finished before step A can begin.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);