const regex = /^(\d*0)\..*\n(?!\d*1\.|(?!\d))|
^(\d*1)\..*\n(?!\d*2\.|(?!\d))|
^(\d*2)\..*\n(?!\d*3\.|(?!\d))|
^(\d*3)\..*\n(?!\d*4\.|(?!\d))|
^(\d*4)\..*\n(?!\d*5\.|(?!\d))|
^(\d*5)\..*\n(?!\d*6\.|(?!\d))|
^(\d*6)\..*\n(?!\d*7\.|(?!\d))|
^(\d*7)\..*\n(?!\d*8\.|(?!\d))|
^(\d*8)\..*\n(?!\d*9\.|(?!\d))|
^(\d*9)\..*\n(?!\d*0\.|(?!\d))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\d*0)\\..*\\n(?!\\d*1\\.|(?!\\d))|
^(\\d*1)\\..*\\n(?!\\d*2\\.|(?!\\d))|
^(\\d*2)\\..*\\n(?!\\d*3\\.|(?!\\d))|
^(\\d*3)\\..*\\n(?!\\d*4\\.|(?!\\d))|
^(\\d*4)\\..*\\n(?!\\d*5\\.|(?!\\d))|
^(\\d*5)\\..*\\n(?!\\d*6\\.|(?!\\d))|
^(\\d*6)\\..*\\n(?!\\d*7\\.|(?!\\d))|
^(\\d*7)\\..*\\n(?!\\d*8\\.|(?!\\d))|
^(\\d*8)\\..*\\n(?!\\d*9\\.|(?!\\d))|
^(\\d*9)\\..*\\n(?!\\d*0\\.|(?!\\d))', 'gm')
const str = `1. And this is line one
2. So this is line two
4. I think I missed something here...
5. Carrying on.
6. Feeling cozy again.
8. Wait, I missed something again.
10. I just missed more somethings again.
13. Dude, what's happening?
14. Things are alright again.
15. Still good.
17. Whoops, bubble.
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}