import Foundation
let pattern = #"""
^(\d*0)\..*\n(?!\d*1\.|(?!\d))|
^(\d*1)\..*\n(?!\d*2\.|(?!\d))|
^(\d*2)\..*\n(?!\d*3\.|(?!\d))|
^(\d*3)\..*\n(?!\d*4\.|(?!\d))|
^(\d*4)\..*\n(?!\d*5\.|(?!\d))|
^(\d*5)\..*\n(?!\d*6\.|(?!\d))|
^(\d*6)\..*\n(?!\d*7\.|(?!\d))|
^(\d*7)\..*\n(?!\d*8\.|(?!\d))|
^(\d*8)\..*\n(?!\d*9\.|(?!\d))|
^(\d*9)\..*\n(?!\d*0\.|(?!\d))
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .allowCommentsAndWhitespace])
let testString = #"""
1. And this is line one
2. So this is line two
4. I think I missed something here...
5. Carrying on.
6. Feeling cozy again.
8. Wait, I missed something again.
10. I just missed more somethings again.
13. Dude, what's happening?
14. Things are alright again.
15. Still good.
17. Whoops, bubble.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)