#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.+\..+,.+,.+$"
Local $sString = "A sentence, some words" & @CRLF & _
"ABCD.CP3,GHD,HDID" & @CRLF & _
"Hello. How are you? " & @CRLF & _
"A.B,C,D" & @CRLF & _
"dbibb.yes,whoami,words"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")