re = /^.+\..+,.+,.+$/m
str = 'A sentence, some words
ABCD.CP3,GHD,HDID
Hello. How are you?
A.B,C,D
dbibb.yes,whoami,words'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end