const regex = /(?=^test\s+.*|.*?\s+test\s+.*?|.*?\s+test$).*/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=^test\\s+.*|.*?\\s+test\\s+.*?|.*?\\s+test$).*', '')
const str = `test is test is test
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}