$re = '/(?=^test\s+.*|.*?\s+test\s+.*?|.*?\s+test$).*/';
$str = 'test is test is test
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);