use strict;
my $str = 'AccountUserID';
my $regex = qr/(?<![A-Z])\B(?=[A-Z])/p;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";