$re = '/(?<![A-Z])\B(?=[A-Z])/';
$str = 'AccountUserID';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;