using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\d)(\d{5})\d(?=\d{5}(?!\d))";
string substitution = @"\1";
string input = @"08001301001
08002401002 / 08002601003 / 17134604034
08004701005 / 08005101001";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}