$re = '/\b(they|he|she|her|him|them|it)\b/m';
$str = 'they he she her him them it kit sherpa shim himself themselves';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);