re = /\b(they|he|she|her|him|them|it)\b/m
str = 'they he she her him them it kit sherpa shim himself themselves'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end