# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[^.?!]*(?<=[.?\s!])flung(?=[\s.?!])[^.?!]*[.?!]//igm;t' <<< "As she did so, a most extraordinary thing happened. The bed-clothes gathered themselves together, leapt up suddenly into a sort of peak, and then jumped headlong over the bottom rail. It was exactly as if a hand had clutched them in the centre and flung them aside. Immediately after, ........."