const regex = /[^.?!]*(?<=[.?\s!])flung(?=[\s.?!])[^.?!]*[.?!]/igm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^.?!]*(?<=[.?\\s!])flung(?=[\\s.?!])[^.?!]*[.?!]', 'igm')
const str = `As she did so, a most extraordinary thing happened. The bed-clothes gathered themselves together, leapt up suddenly into a sort of peak, and then jumped headlong over the bottom rail. It was exactly as if a hand had clutched them in the centre and flung them aside. Immediately after, .........`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);