package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\+44`)
var str = `+44 1234-554-6345`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}