$re = '/^\+44/m';
$str = '+44 1234-554-6345';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);