using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*)(-.*){2}";
string substitution = @"$1";
string input = @"M-1030-SIS422-1029-XS
JACKSON-0003-28";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}