$re = '/(.*)(-.*){2}/';
$str = 'M-1030-SIS422-1029-XS
JACKSON-0003-28';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;