#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^\[([^\]]+)]:.*for\s(.+)\s\(ID:\s(\d+)\).*\s(\d{0,3}(?::\d{0,3}){3}).*\s([a-zA-z\d]+)$"
Local $sString = "[20-Nov-2015 14:49:55 +0200]: Successful login for user name (ID: 299) from 127:0:0:1 in session 70573git16bu1otp0jpugm8q14"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")