using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\[([^\]]+)]:.*for\s(.+)\s\(ID:\s(\d+)\).*\s(\d{0,3}(?::\d{0,3}){3}).*\s([a-zA-z\d]+)$";
string input = @"[20-Nov-2015 14:49:55 +0200]: Successful login for user name (ID: 299) from 127:0:0:1 in session 70573git16bu1otp0jpugm8q14";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}