const regex = /^\[([^\]]+)]:\sSuccess.*for\s(.+)\s\(ID:\s(\d+)\).*\s(\d{0,3}(?::\d{0,3}){3}).*\s([a-zA-z\d]+)$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\[([^\\]]+)]:\\sSuccess.*for\\s(.+)\\s\\(ID:\\s(\\d+)\\).*\\s(\\d{0,3}(?::\\d{0,3}){3}).*\\s([a-zA-z\\d]+)$', 'g')
const str = `[20-Nov-2015 14:49:55 +0200]: Successful login for user name (ID: 299) from 127:0:0:1 in session 70573git16bu1otp0jpugm8q14`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}