// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^\[([^\]]+)]:\sSuccess.*for\s(.+)\s\(ID:\s(\d+)\).*\s(\d{0,3}(?::\d{0,3}){3}).*\s([a-zA-z\d]+)$").unwrap();
let string = "[20-Nov-2015 14:49:55 +0200]: Successful login for user name (ID: 299) from 127:0:0:1 in session 70573git16bu1otp0jpugm8q14";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}