const regex = new RegExp('^(?i).*(?P<fileExt>\\.mka)$', '')
const str = `[TxxZ&A.I.R.nesSub][Library_Wars][The_Last_Mission][BDRIP][1920x1080][HEVC_AC3x2].mka`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}