package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\w+:(\\[^\\]+){2}\\(?<host>[^\\]+)`)
var str = `D:\14. splunk\SMT\PC123\logfile.log`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}