$re = '/^\w+:(\\\\[^\\\\]+){2}\\\\(?<host>[^\\\\]+)/m';
$str = 'D:\\14. splunk\\SMT\\PC123\\logfile.log';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);