# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<([^>]*)>[^><]*<\\/\s*\1\s*>|<(\w+)\s+[^>]*>[^><]*<\\/\s*\2\s*>//gm;t' <<< "<div id=\"MyDiv\">div,
<strong>
<span>span2, </span> <-- This is to delete
<em> Some text for em
<div> Some text for div </div> <-- This is to delete
<p><b>b, <span id=\"MySpan\"> Some text for span ...
<b style=\"z-index:1;\"> text ... </ b >"