re = /<([^>]*)>[^><]*<\/\s*\1\s*>|<(\w+)\s+[^>]*>[^><]*<\/\s*\2\s*>/m
str = '<div id="MyDiv">div,
<strong>
<span>span2, </span> <-- This is to delete
<em> Some text for em
<div> Some text for div </div> <-- This is to delete
<p><b>b, <span id="MySpan"> Some text for span ...
<b style="z-index:1;"> text ... </ b >'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result