re = /[ \S]+?SMTP connection from \S+? \(TCP\/IP connection count = (?!\b1\b|\b2\b|\b3\b)\d+\)/m
str = '2014-11-27 17:09:05 SMTP connection from [42.117.255.244] (TCP/IP connection count = 1)
2014-11-27 17:09:14 SMTP connection from [118.68.249.18] (TCP/IP connection count = 2)
2014-11-27 17:09:15 SMTP connection from [113.188.85.220] (TCP/IP connection count = 3)
2014-11-27 17:09:15 SMTP connection from [113.188.85.220] (TCP/IP connection count = 5)
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end