re = /^(?!\babc:\b|\bdefg:\b).*$/m
str = 'abc:sadasd
defg:asdasdsa
asgdashgdsadas
asdsadasd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end