package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d+(?:\.\d+))|(\w+)`)
var str = `custPowerCourse := 11.1,22.2,33.3,44.4,55.5`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}